Failing uploads in EU
Incident Report for WeTransfer
Postmortem

In the morning we started a deployment of a system that processes our uploads. The system caused an increased load on S3, our storage system. This load caused some uploads to be refused in-flight and the processing of the uploads was delayed by about 30 minutes.

Once we knew what the issue was, we rolled the system back and we contacted AWS about the issues we were experiencing. They are putting the necessary fixes into place so that the deploy will not cause comparable issues in the future.

Posted Jun 21, 2016 - 15:29 UTC

Resolved
We have identified the issue. After some work we managed to process all the hung uploads and we ensured that the uploads will process normally.
Posted Jun 21, 2016 - 15:23 UTC
Identified
Due to a sudden burst in load we are having a problem handling file uploads. We are currently investigating the problem and hope to have it resolved shortly.
Posted Jun 21, 2016 - 14:01 UTC