Delay in processing EU uploads
Incident Report for WeTransfer
Resolved
Some parts of EU processing were not performing optimally, creating a slowdown for uploads in the EU. We replaced the underperforming parts and are back in business. All uploads are being processed optimally again.
Posted Jul 05, 2016 - 10:42 UTC
Identified
Currently new transfers uploaded in the EU region may take up to 30 minutes to process. Our engineers are working hard to reduce the waiting time.
Posted Jul 05, 2016 - 10:19 UTC