Hiccups with download handling and upload processing
Incident Report for WeTransfer
Resolved
All transfers that were stuck have been processed now.
Posted May 02, 2016 - 14:39 UTC
Investigating
Some users may experience issues when attempting downloads on our EU servers. Processing of uploaded transfers may also be affected for a small percentage of users. Hopefully the problem will be resolved soon.
Posted May 02, 2016 - 13:39 UTC