Processing of US uploads is delayed
Incident Report for WeTransfer
Resolved
At 12:30 PM PDT the last entries from the queue had been processed, which means every transfer should have reached its destination by now. Thank you for your patience.
Posted Jul 05, 2016 - 19:45 UTC
Identified
Yesterday, we switched over to a new processing backend that had been running succesfully in the EU for a while. However, this morning around 5 AM PDT, the new processing backend grinded to a halt. We rolled back to the old one around 6:30 AM PDT. After some thorough investigation in cooperation with Amazon AWS the issue has been identified. All transfers uploaded between 5 AM and 6:30 AM PDT should be processed somewhere this evening. Transfers uploaded outside this timeframe are not affected.
Posted Jul 05, 2016 - 16:58 UTC
Investigating
Processing uploads for US servers are severely delayed. We are currently investigating the issue and trying to improve the process time.
Posted Jul 05, 2016 - 14:58 UTC