Impaired website performance
Incident Report for WeTransfer
Resolved
Performance has restored to normal levels, the website is again available
Posted about 1 year ago. Nov 03, 2016 - 17:06 UTC
Investigating
We are experiencing a severe drop in performance on the main website, we are currently investigating.
Posted about 1 year ago. Nov 03, 2016 - 16:03 UTC