Email processing affected
Incident Report for WeTransfer
Resolved
By the looks of it, Sendgrid has taken care of the problem entirely: http://status.sendgrid.com/
Posted 11 months ago. Aug 25, 2016 - 17:44 UTC
Identified
Our email processor Sendgrid is currently working hard to fix an issue. Email addresses used to transfer could be blocked, more information available here: http://status.sendgrid.com/
Posted 11 months ago. Aug 25, 2016 - 17:05 UTC