Processing delays
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 20, 2017 - 19:05 UTC
Identified
At the moment we are seeing an uptick in the time it takes to process certain transfers caused by a strain on the database. You could see a message stating that your files are missing while they’re not. This shouldn’t take longer than 30 minutes after the upload is completed to be resolved.
Posted about 1 month ago. Jun 20, 2017 - 15:22 UTC