Impaired website performance
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted 7 months ago. Dec 15, 2016 - 11:22 UTC
Monitoring
We identified an issue with our database and put measures in place to resolve the issue. The situation has stabilised and the site is back up. We are currently monitoring the situation.
Posted 7 months ago. Dec 15, 2016 - 10:58 UTC
Investigating
We are experiencing a severe drop in performance on the main website, which we are currently investigating. We will keep you updated as we know more.
Posted 7 months ago. Dec 15, 2016 - 10:52 UTC