Degraded performance
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 10, 2017 - 07:33 UTC
Monitoring
Earlier today, we noticed some instances where part of our US backend failed to catch up with demand on the platform. We've located the issue and rolled out a fix for these servers. We'll be monitoring the situation until all components of our platform are back up to speed again.
Posted 6 months ago. Apr 10, 2017 - 06:21 UTC