Impaired website performance
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted 8 months ago. Nov 30, 2016 - 16:44 UTC
Investigating
We are experiencing a severe drop in performance on the main website, we are currently investigating.
Posted 8 months ago. Nov 30, 2016 - 14:41 UTC